Plesk won’t start or gives 500 error

Plesk wont start or gives 500 error on loading in browser.

service sw-cp-server start

The status will be failed

Starting SWsoft control panels server… stale pidfile. [FAILED]

Check the Plesk error log /var/log/sw-cp-server/error_log.

tail -f /var/log/sw-cp-server/error_log

2013-06-26 20:51:20: (network.c.371) can’t bind to port: 127.0.0.1 10001 Address already in use
2013-06-26 20:53:45: (log.c.166) server started
2013-06-26 20:53:45: (network.c.371) can’t bind to port: 127.0.0.1 10001 Address already in use
2013-06-26 20:53:45: (log.c.166) server started
2013-06-26 20:53:45: (network.c.371) can’t bind to port: 127.0.0.1 10001 Address already in use
2013-06-26 20:53:50: (log.c.166) server started
2013-06-26 20:53:50: (network.c.371) can’t bind to port: 127.0.0.1 10001 Address already in use

Check what is open on port 10001.

lsof -i tcp:10001

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
sw-cp-ser 14726 sw-cp-server 5u IPv4 4145375026 0t0 TCP localhost:scp-config (LISTEN)

Stop The Plesk service.
service sw-cp-server stop

Stoppping SWsoft control panels server… not running. [ OK ]

Remove the Plesk PID.
rm -rf /var/run/sw-cp-server.pid

Check if the Plesk process is still running.

# ps ax | grep sw-cp-server | grep -v grep
14726 ? S 0:00 /usr/sbin/sw-cp-serverd -f /etc/sw-cp-server/config

Kill the process.
ps ax | grep sw-cp-server | grep -v grep | xargs kill -9

Start Plesk.
service sw-cp-server start

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s